unable to install prerequisite for VS 2008

Oct 11, 2008 at 5:37 PM
Edited Oct 11, 2008 at 5:38 PM

When I try to install the prerequisite Guidance Automation for Visual Studio 2008
prior to installing the Guidance Automation Extensions, I get this error:

Guidance Automation Extensions support for Visual Studio 2008 or Visual Studio 2008 is not installed. Click OK to exit.

I'm running Vista Ultimate SP1, Visual Studio 2008 SP1, .Net Framework 3.5 SP1.

Any suggestions would be helpful.

Coordinator
Oct 11, 2008 at 7:52 PM
Edited Oct 11, 2008 at 10:52 PM
Hello fmorriso,

You need to install the packages in the following order
  1. When using Visual Studio 2008 with SP1 you need the Hotfix Guidance Automation Extensions for Visual Studio 2008 and Visual Studio 2008 Service Pack 1 Update (GAXP1409)
  2. Guidance Automation Extensions
  3. Guidance Automation Toolkit (only needed if you want to edit the source sode of the software factory) 
  4. Install SPALM Software Factory
  5. Probably you may also need the GAX Extension Library (also only required if you want to edit the source sode of the software factory, otherwhise it is included in the SPALM setup package)
Please let us know if you have any further problems.

Before you start the described installations, please make sure that GAX, GAT and SPALM are uninstalled (BTW, you can uninstall GAX before GAT through "Add and Remove Programs", but if you do so the GAT uninstallation will fail! So just do it the other way round ;-))

Matt



Mar 17, 2009 at 11:14 PM
I have the same problem, and the solution you described is not ok, do you have any other work around?
same config as fmorriso

Regards,
Stefan
http://www.itsconsulting.fr
Coordinator
Mar 18, 2009 at 8:45 AM
What exactly have you installed? VS2008 with or without SP1?
Have you tried uninstalling the GAE and GAT packages before reinstalling?